Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-9663

InnoDB assertion failure: *cursor->index->name == TEMP_INDEX_PREFIX, or !cursor->index->is_committed()

    XMLWordPrintable

    Details

      Description

      A Windows user upgraded from MariaDB 10.0.21 to MariaDB 10.1.11. After running mysql_upgrade, the user saw errors like this in the error log:

      InnoDB: tried to purge sec index entry not marked for deletion in
      InnoDB: index "column" of table "db1"."tab1"
      InnoDB: tuple DATA TUPLE: 3 fields;
       0: len 15; hex XXXX; asc field1;;
       1: len 3; hex XXXX; asc sum;;
       2: len 33; hex XXXX; asc field3;;
       
      InnoDB: record PHYSICAL RECORD: n_fields 3; compact format; info bits 0
       0: len 15; hex XXXX; asc field1;;
       1: len 3; hex XXXX; asc sum;;
       2: len 30; hex XXXX; asc field3; (total 33 bytes);
      

      Some time after that, the user tried inserting more records into the database, and this caused an assertion failure:

      2016-02-12 14:58:34 4428  InnoDB: Assertion failure in thread 17448 in file row0ins.cc line 283
      InnoDB: Failing assertion: *cursor->index->name == TEMP_INDEX_PREFIX
      InnoDB: We intentionally generate a memory trap.
      InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
      InnoDB: If you get repeated assertion failures or crashes, even
      InnoDB: immediately after the mysqld startup, there may be
      InnoDB: corruption in the InnoDB tablespace. Please refer to
      InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
      InnoDB: about forcing recovery.
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                thiru Thirunarayanan Balathandayuthapani
                Reporter:
                GeoffMontee Geoff Montee
              • Votes:
                7 Vote for this issue
                Watchers:
                20 Start watching this issue

                Dates

                • Created:
                  Updated: