Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-20137

rpl.mdev_17588 fails in buildbot with "Table doesn't exist"

    XMLWordPrintable

    Details

      Description

      http://buildbot.askmonty.org/buildbot/builders/kvm-bintar-quantal-x86/builds/18138/steps/mtr/logs/stdio

      10.1 4aa97ba5944f4afe751525e68b77100b

      rpl.mdev_17588 'innodb_plugin,mix'       w3 [ fail ]
              Test ended at 2019-07-19 10:13:51
       
      CURRENT_TEST: rpl.mdev_17588
      mysqltest: At line 22: query 'show create table t2' failed: 1146: Table 'test.t2' doesn't exist
       
      The result from queries just before the failure was:
      < snip >
      [connection master]
      create table t1 (a int) engine=innodb;
      create table t2 (a int);
      create table t3 (a int) engine=innodb;
      include/save_master_gtid.inc
      include/wait_for_slave_sql_error.inc [errno=1286]
      Last_Error = 'Error 'Unknown storage engine 'innodb'' on query. Default database: 'test'. Query: 'create table t1 (a int) engine=innodb''
      STOP SLAVE IO_THREAD;
      include/wait_for_slave_to_stop.inc
      SET GLOBAL SQL_SLAVE_SKIP_COUNTER=1;
      include/start_slave.inc
      include/sync_with_master_gtid.inc
      show tables;
      Tables_in_test
      show create table t2;
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              sachin.setiya.007 Sachin Setiya
              Reporter:
              elenst Elena Stepanova
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: