Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-20240

Master/Master slave sync not working

    XMLWordPrintable

    Details

      Description

      Hi.
      Were running mariadb in master/master configuration o two servers. After upgrading to 10.1.41, the slave sync stopped working.
      show slave status shows nothing wrong, but the server will hang when issuing "stop slave".
      also no message sare syncronized.

      Reverting server to 10.1.40 fixes problem.
      Both upgrading an existing working install, and starting from scratch fails the same way.
      The configuration we use have worked for us for about three years .

      I do not know what type of info is needed to diagnose the issue.

      Attached is the server config file from /etc/mysql/conf.d. Default my.cfg from installer package is used.

      Initial sync is started by copying the main db from one unit to the other, and tehn setting the binlog position:
      set global gtid_slave_pos='position fro other server'
      and starting sync:
      change master to master_host='controlserver2', master_user='replication', master_password='${pw}', master_use_gtid=slave_pos;";

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Elkin Andrei Elkin
              Reporter:
              RuneTorgersen Rune Torgersen
              Votes:
              3 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: