This should be used instead of a such arguments T *ptr, size_t size, const std::vector<T> &v.
Especially pointer and size pair is harmful: easy to use incorrect, hard to read the code.
Class is non-owning! It's just a reference to something.
Do not use it for strings! Another things exists for strings: https://en.cppreference.com/w/cpp/string/basic_string_view
Suggestion to use are here https://isocpp.github.io/CppCoreGuidelines/CppCoreGuidelines