Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-15565

CentOS 7 net-snmp cannot be installed because it tries to install mariadb-libs which fails

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 10.0.34
    • Fix Version/s: 10.0
    • Component/s: Packaging
    • Labels:
      None
    • Environment:
      CentOS Linux release 7.4.1708
      3.10.0-693.11.6.el7.x86_64
      MariaDB-server-10.0.34-1.el6.x86_64

      Description

      Hi

      i am trying to install
      net-snmp
      net-snmp-agent-libs
      net-snmp-libs
      and i can't ...

      Total size: 2.5 M
      Total download size: 757 k
      Is this ok [y/d/N]: y
      Downloading packages:
      mariadb-libs-5.5.56-2.el7.x86_64.rpm                                                                                                                     | 757 kB  00:00:00
      Running transaction check
      Running transaction test
       
       
      Transaction check error:
        file /etc/my.cnf from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-common-10.0.34-1.el6.x86_64
        file /usr/lib64/mysql/plugin/dialog.so from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-common-10.0.34-1.el6.x86_64
        file /usr/lib64/mysql/plugin/mysql_clear_password.so from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-common-10.0.34-1.el6.x86_64
        file /usr/share/mysql/czech/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/danish/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/dutch/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/english/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/estonian/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/french/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/german/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/greek/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/hungarian/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/italian/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/japanese/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/korean/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/norwegian/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/polish/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/portuguese/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/romanian/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/russian/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/serbian/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/slovak/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/spanish/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/swedish/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
        file /usr/share/mysql/ukrainian/errmsg.sys from install of mariadb-libs-1:5.5.56-2.el7.x86_64 conflicts with file from package MariaDB-server-10.0.34-1.el6.x86_64
       
      Error Summary
      -------------
      
      

      It is already solved for 10.1.1 (MDEV-7064)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                svoj Sergey Vojtovich
                Reporter:
                zar Sistemisti Netsons
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: