Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-7064

CentOS 7 net-snmp cannot be installed because it tries to install mariadb-libs which fails

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 10.1.1
    • Fix Version/s: 10.1.2
    • Component/s: Packaging
    • Labels:
      None
    • Environment:
      CentOS 7 default install with MariaDB 10.1.1 from mariadb repo instead of built in

      Description

      because MariaDB-server replaces key files that mariadb-libs would install in the base OS you cannot install any packages that require mariadb-libs once MariaDB-server is installed

      one such package is net-snmp which fails with following error:

      [root@qa-linux ~]# yum install net-snmp
      Loaded plugins: fastestmirror, priorities
      Loading mirror speeds from cached hostfile
       * base: mirror.zol.co.zw
       * epel: mirror.zol.co.zw
       * extras: mirror.zol.co.zw
       * updates: mirror.zol.co.zw
      88 packages excluded due to repository priority protections
      Resolving Dependencies
      --> Running transaction check
      ---> Package net-snmp.x86_64 1:5.7.2-18.el7 will be installed
      --> Processing Dependency: libmysqlclient.so.18()(64bit) for package: 1:net-snmp-5.7.2-18.el7.x86_64
      --> Running transaction check
      ---> Package mariadb-libs.x86_64 1:5.5.37-1.el7_0 will be installed
      --> Finished Dependency Resolution
       
      Dependencies Resolved
       
      ============================================================================================================================================================================================================================================================================
       Package                                                            Arch                                                         Version                                                                Repository                                                     Size
      ============================================================================================================================================================================================================================================================================
      Installing:
       net-snmp                                                           x86_64                                                       1:5.7.2-18.el7                                                         base                                                          319 k
      Installing for dependencies:
       mariadb-libs                                                       x86_64                                                       1:5.5.37-1.el7_0                                                       updates                                                       752 k
       
      Transaction Summary
      ============================================================================================================================================================================================================================================================================
      Install  1 Package (+1 Dependent package)
       
      Total size: 1.0 M
      Installed size: 5.2 M
      Is this ok [y/d/N]: y
      Downloading packages:
      Running transaction check
      Running transaction test
       
       
      Transaction check error:
        file /etc/my.cnf from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-common-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/czech/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/danish/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/dutch/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/english/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/estonian/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/french/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/german/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/greek/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/hungarian/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/italian/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/japanese/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/korean/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/norwegian/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/polish/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/portuguese/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/romanian/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/russian/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/serbian/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/slovak/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/spanish/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/swedish/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
        file /usr/share/mysql/ukrainian/errmsg.sys from install of mariadb-libs-1:5.5.37-1.el7_0.x86_64 conflicts with file from package MariaDB-server-10.1.1-1.el7.centos.x86_64
       
      Error Summary

      its probably a good plan to make MariaDB-server obsolete or provide mariadb-libs for backwards compatibility

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                anthonysomerset Anthony Somerset
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: