Uploaded image for project: 'MariaDB ColumnStore'
  1. MariaDB ColumnStore
  2. MCOL-994

cpimport failed with a "new extent FBO too high for current file error"

    XMLWordPrintable

    Details

    • Sprint:
      2017-22, 2017-23, 2017-24

      Description

      Build tested: 1.1.1.-1 package file

      Stack: 1um4pm, each pm has 1 dbroot

      1. created dbt3 tables
      2. cpimport 10g source
      3. cpimport 10g source again
      4. redistribute start remove 2
      5. cpimport 100g source and failure occurred

      All other tables import successfully. I tried to load the partsupp table again and got the same error

      OID-3073 is the ps_supplycost column.

      The following is the extent map after cpimport failed and rolled back.

      [root@localhost columnstore]# /usr/local/mariadb/columnstore/bin/editem -o 3073
      Col OID = 3073, NumExtents = 4, width = 8
      878592 - 886783 (8192) min: 100, max: 100000, seqNum: 3, state: valid, fbo: 0, DBRoot: 4, part#: 0, seg#: 0, HWM: 5863; status: avail
      1977344 - 1985535 (8192) min: 100, max: 100000, seqNum: 3, state: valid, fbo: 0, DBRoot: 1, part#: 0, seg#: 1, HWM: 8191; status: avail
      2006016 - 2014207 (8192) min: 100, max: 100000, seqNum: 3, state: valid, fbo: 0, DBRoot: 1, part#: 0, seg#: 2, HWM: 5863; status: avail
      2051072 - 2059263 (8192) min: 100, max: 100000, seqNum: 3, state: valid, fbo: 0, DBRoot: 3, part#: 0, seg#: 3, HWM: 5863; status: avail

        Attachments

          Activity

            People

            Assignee:
            dleeyh Daniel Lee
            Reporter:
            dleeyh Daniel Lee
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.