Uploaded image for project: 'MariaDB ColumnStore'
  1. MariaDB ColumnStore
  2. MCOL-5060

Clean up legacy OAM remnants

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 6.2.3
    • Fix Version/s: 6.4.1
    • Component/s: installation
    • Labels:
      None

      Description

      columnstore-post-install contains some code that needs cleanup as well as a reference to obsolete software. This is breaking some installs.

      [root@1224989474ee /]# dnf -y install MariaDB-columnstore-engine
      Last metadata expiration check: 0:01:01 ago on Thu Apr 21 16:41:54 2022.
      Dependencies resolved.
      ===============================================================================================================================================================================================================================================================
       Package                                                                Architecture                                       Version                                                           Repository                                                   Size
      ===============================================================================================================================================================================================================================================================
      Installing:
       MariaDB-columnstore-engine                                             x86_64                                             10.6.7_3_6.2.3-1.el8                                              mariadb-es-main                                             7.4 M
       
      Transaction Summary
      ===============================================================================================================================================================================================================================================================
      Install  1 Package
       
      Total download size: 7.4 M
      Installed size: 7.4 M
      Downloading Packages:
      MariaDB-columnstore-engine-10.6.7_3_6.2.3-1.el8.x86_64.rpm                                                                                                                                                                     9.2 MB/s | 7.4 MB     00:00
      ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
      Total                                                                                                                                                                                                                          9.1 MB/s | 7.4 MB     00:00
      Running transaction check
      Transaction check succeeded.
      Running transaction test
      Transaction test succeeded.
      Running transaction
        Preparing        :                                                                                                                                                                                                                                       1/1
        Running scriptlet: MariaDB-columnstore-engine-10.6.7_3_6.2.3-1.el8.x86_64                                                                                                                                                                                1/1
        Installing       : MariaDB-columnstore-engine-10.6.7_3_6.2.3-1.el8.x86_64                                                                                                                                                                                1/1
        Running scriptlet: MariaDB-columnstore-engine-10.6.7_3_6.2.3-1.el8.x86_64                                                                                                                                                                                1/1
      checking for engine columnstore...
      columnstore exists
      strings: '/proc/0/environ': No such file
      error: process ID out of range
       
      Usage:
       ps [options]
       
       Try 'ps --help <simple|list|output|threads|misc|all>'
        or 'ps --help <s|l|o|t|m|a>'
       for additional help text.
       
      For more details see ps(1).
      strings: '/proc//environ': No such file
      /bin/columnstore-post-install: line 18: [: too many arguments
      strings: '/proc/0/environ': No such file
      error: process ID out of range
       
      Usage:
       ps [options]
       
       Try 'ps --help <simple|list|output|threads|misc|all>'
        or 'ps --help <s|l|o|t|m|a>'
       for additional help text.
       
      For more details see ps(1).
      strings: '/proc//environ': No such file
      /bin/columnstore-post-install: line 18: [: too many arguments
      strings: '/proc/0/environ': No such file
      error: process ID out of range
       
      Usage:
       ps [options]
       
       Try 'ps --help <simple|list|output|threads|misc|all>'
        or 'ps --help <s|l|o|t|m|a>'
       for additional help text.
       
      For more details see ps(1).
      strings: '/proc//environ': No such file
      /bin/columnstore-post-install: line 18: [: too many arguments
      strings: '/proc/0/environ': No such file
      error: process ID out of range
       
      Usage:
       ps [options]
       
       Try 'ps --help <simple|list|output|threads|misc|all>'
        or 'ps --help <s|l|o|t|m|a>'
       for additional help text.
       
      For more details see ps(1).
      strings: '/proc//environ': No such file
      /bin/columnstore-post-install: line 18: [: too many arguments
      strings: '/proc/0/environ': No such file
      error: process ID out of range
       
      Usage:
       ps [options]
       
       Try 'ps --help <simple|list|output|threads|misc|all>'
        or 'ps --help <s|l|o|t|m|a>'
       for additional help text.
       
      For more details see ps(1).
      strings: '/proc//environ': No such file
      /bin/columnstore-post-install: line 18: [: too many arguments
      strings: '/proc/0/environ': No such file
      error: process ID out of range
       
      Usage:
       ps [options]
       
       Try 'ps --help <simple|list|output|threads|misc|all>'
        or 'ps --help <s|l|o|t|m|a>'
       for additional help text.
       
      For more details see ps(1).
      strings: '/proc//environ': No such file
      /bin/columnstore-post-install: line 18: [: too many arguments
      strings: '/proc/0/environ': No such file
      error: process ID out of range
       
      Usage:
       ps [options]
       
       Try 'ps --help <simple|list|output|threads|misc|all>'
        or 'ps --help <s|l|o|t|m|a>'
       for additional help text.
       
      For more details see ps(1).
      strings: '/proc//environ': No such file
      /bin/columnstore-post-install: line 18: [: too many arguments
      strings: '/proc/0/environ': No such file
      error: process ID out of range
       
      Usage:
       ps [options]
       
       Try 'ps --help <simple|list|output|threads|misc|all>'
        or 'ps --help <s|l|o|t|m|a>'
       for additional help text.
       
      For more details see ps(1).
      strings: '/proc//environ': No such file
      /bin/columnstore-post-install: line 18: [: too many arguments
      strings: '/proc/0/environ': No such file
      error: process ID out of range
       
      Usage:
       ps [options]
       
       Try 'ps --help <simple|list|output|threads|misc|all>'
        or 'ps --help <s|l|o|t|m|a>'
       for additional help text.
       
      For more details see ps(1).
      strings: '/proc//environ': No such file
      /bin/columnstore-post-install: line 18: [: too many arguments
      Populating the engine initial system catalog.
       
        Verifying        : MariaDB-columnstore-engine-10.6.7_3_6.2.3-1.el8.x86_64                                                                                                                                                                                1/1
       
      Installed:
        MariaDB-columnstore-engine-10.6.7_3_6.2.3-1.el8.x86_64
       
      Complete!
      

      The offending code is here:

      https://github.com/mariadb-corporation/mariadb-columnstore-engine/blob/develop-6/oam/install_scripts/columnstore-post-install.in#L15-L25

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dleeyh Daniel Lee
              Reporter:
              toddstoffel Todd Stoffel
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Git Integration

                  Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.