Uploaded image for project: 'MariaDB ColumnStore'
  1. MariaDB ColumnStore
  2. MCOL-3948

1.4 install and upgrade guides needs more details on S3 setup

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: N/A
    • Component/s: Documentation
    • Labels:
      None

      Description

      Currently in the multi-node guides it mentions that there is additional setup required to use Storage Manager

      "If you would like to use any sort of storage manager, you need to install and configure it prior to installing MariaDB ColumnStore."

      Need to document what this is or a link to what needs to be setup. I didn't do anything for this step and when I ran postConfigure to select S3, I got this in the description.

      4 - S3-compatible cloud storage *. Note: that should be configured
      before running postConfigure (see storagemanager.cnf)

      So I assume setting up this file, storagemanager.cnf, is what is meant by the first statement.

      In searching for this cnf file, I only found info about it in the release notes. Should it be somewhere else like in a setup or configure Columnstore system or having it just in the release notes good enough.

      https://mariadb.com/docs/release-notes/mariadb-columnstore-1-4-2-release-notes/#s3-storage-manager

      And should the install/upgrade docs point back to the release notes?

      Also this is in the release notes, if pointing here, then this requires a specific location where the file resides

      "Before running postConfigure, edit the storagemanager.cnf configuration file to specify the S3"

        Attachments

          Activity

            People

            Assignee:
            GeoffMontee Geoff Montee
            Reporter:
            hill David Hill (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.