Being able to handle specific errors is great with the Exception's "errno". It would be a lot neater if there were constants for this instead of numbers - to promote better readability.
documents = domino.get_all("Sales Order")
except OperationalError as err:
if err.errno == ER.LOCK_WAIT_TIMEOUT:
logger.exception("Lock wait timeout error ocurred")