Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-41031

Database Restore Failure Due to Unsupported Generated Column (STR_TO_DATE)

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Critical
    • Resolution: Not a Bug
    • None
    • N/A
    • Backup
    • None
    • Not for Release Notes

    Description

      We are encountering a failure during the MySQL database restore process caused by a generated column definition. Specifically, the restore halts when attempting to recreate a column defined using the STR_TO_DATE function as a generated expression. This incompatibility prevents the database from being imported successfully.

      Error code is as shown below:

      ERROR 1901 (HY000) at line 1087:
      Function or expression 'str_to_date()' cannot be used in the GENERATED ALWAYS AS clause of 'task_dt'

      We are trying to do mysqldump backup from the old server MariaDB 10.6 and then restore onto the new server MariaDB 12.3, how do we proceed?

      Attachments

        1. mdev-41031_11.8.8_dump.sql
          3 kB
          Shipra Jain
        2. mdev-41031_restore.test
          0.1 kB
          Shipra Jain
        3. Screenshot 2026-09-07 113538.png
          905 kB
          Shat Shen Lim

        Activity

          People

            Unassigned Unassigned
            shatshenn Shat Shen Lim
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.