Details
-
Bug
-
Status: Closed (View Workflow)
-
Critical
-
Resolution: Not a Bug
-
None
-
None
-
Not for Release Notes
Description
We are encountering a failure during the MySQL database restore process caused by a generated column definition. Specifically, the restore halts when attempting to recreate a column defined using the STR_TO_DATE function as a generated expression. This incompatibility prevents the database from being imported successfully.
Error code is as shown below:
ERROR 1901 (HY000) at line 1087:
Function or expression 'str_to_date()' cannot be used in the GENERATED ALWAYS AS clause of 'task_dt'
We are trying to do mysqldump backup from the old server MariaDB 10.6 and then restore onto the new server MariaDB 12.3, how do we proceed?