Details
-
Bug
-
Status: Open (View Workflow)
-
Major
-
Resolution: Unresolved
-
10.11, 11.8, 12.3, 10.6.28
-
Q1/2027 Replic. Maintenance
Description
Errors like "This xid already exists" (Error 12605) are seen in error logs of an user at applying
replicated XA transaction that consists of modifications to Innodb and Spider engine.
Upon some analysis of the user data the optimistic parallel retry is suspected for not clean
rollback of the XA or something of this kind that may lead to the xid object remain in Spider engine prior the transaction re-submits at retry.