Repeating the comment from
It remains unclear what was the role-model for log_slow_query_file_name.
We have a variety of patterns with similar meaning:
but I couldn't find any %_file_name (maybe somewhere in optional plugins, those I didn't check).
So, maybe it should be just log_slow_query_file, like several existing _file's. Or even just log_slow_file, given the variable list
Additionally, the help text for log-basename option contains a reference to this variable/option. It was already wrong before ("log-slow-query-log-file"), and will become even wronger now, so it should be fixed at the same time.