Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-28640

dpkg: warning: old mariadb-server-10.6 package pre-removal script subprocess returned error exit status 1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Stalled (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 10.6, 10.7
    • Fix Version/s: 10.6, 10.7
    • Component/s: Server, Upgrades
    • Labels:
      None
    • Environment:
      Debian 11.3 with sysvinit

      Description

      When I try to upgrade my mariadb packages as part of a routine apt-get dist-upgrade or apt full-upgrade, it fails with the following messages:

      dpkg: mariadb-client-10.6: dependency problems, but removing anyway as you requested: 
      mariadb-server-10.6 depends on mariadb-client-10.6 (>= 1:10.6.7+maria~bullseye). 
      mariadb-client depends on mariadb-client-10.6 (>= 1:10.6.8+maria~bullseye).
       
      Removing mariadb-client-10.6 (1:10.6.7+maria~bullseye) ...
      Setting up mysql-common (1:10.6.8+maria~bullseye) ...
      Setting up mariadb-common (1:10.6.8+maria~bullseye) ...
      Preparing to unpack .../00-mariadb-server-10.6_1%3a10.6.8+maria~bullseye_amd64.deb ...
      Stopping MariaDB database server: mariadbd failed!
      invoke-rc.d: initscript mariadb, action "stop" failed.
      dpkg: warning: old mariadb-server-10.6 package pre-removal script subprocess returned error exit status 1
      dpkg: trying script from the new package instead ...
      Stopping MariaDB database server: mariadbd failed!
      invoke-rc.d: initscript mariadb, action "stop" failed.
      dpkg: error processing archive /tmp/apt-dpkg-install-tGWUd2/00-mariadb-server-10.6_1%3a10.6.8+maria~bullseye_amd64.deb (  --unpack): 
      new mariadb-server-10.6 package pre-removal script subprocess returned error exit status 1
      Starting MariaDB database server: mariadbd . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . failed!
      invoke-rc.d: initscript mariadb, action "start" failed.
      dpkg: error while cleaning up: installed mariadb-server-10.6 package post-installation script subprocess returned error exit status 1
      

      This can then be fixed with apt --fix-broken install, but it's a nuisance and causes enough downtime to have to take the server out of production to upgrade.

      # apt-get -y dist-upgrade
      You might want to run 'apt --fix-broken install' to correct these.
      The following packages have unmet dependencies: 
      mariadb-client-10.6 : Breaks: mariadb-server-10.6 (< 1:10.6.8+maria~bullseye) but 1:10.6.7+maria~bullseye is installed 
      mariadb-server : Depends: mariadb-server-10.6 (>= 1:10.6.8+maria~bullseye) but 1:10.6.7+maria~bullseye is installed 
      mariadb-server-core-10.6 : Breaks: mariadb-server-10.6 (< 1:10.6.8+maria~bullseye) but 1:10.6.7+maria~bullseye is installed
      E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
      

      I am using mariadb's repository.

      deb [arch=amd64] https://ftp.osuosl.org/pub/mariadb/repo/10.6/debian bullseye main
      

        Attachments

          Activity

            People

            Assignee:
            illuusio Tuukka Pasanen
            Reporter:
            herrnoel Eric X
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.