Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-24389

CREATE TABLE ... ENGINE=S3 fails with (errno: 131 "Command not supported by the engine")

    XMLWordPrintable

    Details

      Description

      Create an S3 table fails, but I can create it as InnoDB and then change the engine to S3:

      MariaDB [s3_schema]> create table ts3_001 (id int) engine=s3;
      ERROR 1005 (HY000): Can't create table `s3_schema`.`ts3_001` (errno: 131 "Command not supported by the engine")
      MariaDB [s3_schema]> create table ts3_001 (id int) engine=innodb;
      Query OK, 0 rows affected (0.887 sec)
       
      MariaDB [s3_schema]> alter table ts3_001 engine=s3;
      Query OK, 0 rows affected (1.105 sec)              
      Records: 0  Duplicates: 0  Warnings: 0
       
      MariaDB [s3_schema]> show create table ts3_001;
      +---------+---------------------------------------------------------------------------------------------------------+
      | Table   | Create Table                                                                                            |
      +---------+---------------------------------------------------------------------------------------------------------+
      | ts3_001 | CREATE TABLE `ts3_001` (
        `id` int(11) DEFAULT NULL
      ) ENGINE=S3 DEFAULT CHARSET=latin1 PAGE_CHECKSUM=1 |
      +---------+---------------------------------------------------------------------------------------------------------+
      1 row in set (0.622 sec)
      
      

      If then I copy the same create table and execute it, it fails as well:

      MariaDB [s3_schema]> CREATE TABLE `ts3_002` (
          ->   `id` int(11) DEFAULT NULL
          -> ) ENGINE=S3 DEFAULT CHARSET=latin1 PAGE_CHECKSUM=1;
      ERROR 1005 (HY000): Can't create table `s3_schema`.`ts3_002` (errno: 131 "Command not supported by the engine")
      
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            claudio.nanni Claudio Nanni
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.