Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-24034

Policy CMP0075 is not set during compile

    XMLWordPrintable

    Details

      Description

      -- Looking for unistd.h
      CMake Warning (dev) at /usr/share/cmake-3.16/Modules/CheckIncludeFile.cmake:80 (message):
        Policy CMP0075 is not set: Include file check macros honor
        CMAKE_REQUIRED_LIBRARIES.  Run "cmake --help-policy CMP0075" for policy
        details.  Use the cmake_policy command to set the policy and suppress this
        warning.
        CMAKE_REQUIRED_LIBRARIES is set to:
          m;crypt;dl;-lpthread
        For compatibility with CMake 3.11 and below this check is ignoring it.
      Call Stack (most recent call first):
        zlib/CMakeLists.txt:65 (check_include_file)
      This warning is for project developers.  Use -Wno-dev to suppress it.
      -- Looking for unistd.h - found
      

      Seen on 10.4 at c4f8ccc0f53a4de9ca0cac54392b35348494040c, likely also present in other versions.

      Discussed with wlad who has an idea where the issue is coming from.

        Attachments

          Activity

            People

            Assignee:
            wlad Vladislav Vaintroub
            Reporter:
            Roel Roel Van de Paar
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration