Currently we ship libmariadb.pc (for building against the client library) and mariadb.pc (to build against the server). The latter one is confusing to it's name. I've noticed many people assume mariadb.pc is the client library config.
To avoid ambiguity, I suggest that in MariaDB 10.6 we rename it to mariadbd.pc (instead of mariadb.pc). Or even libmariadbd.pc (to be symmetric with libmariadb.pc). The -d is used in libmariadbd package names already and is kind of a convention.
As a bonus, this would help avoid some Lintian complaints that stem from this naming scheme confusion: