Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-14875

galera_new_cluster crashes mysqld when existing server contains databases

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 10.2.12
    • Fix Version/s: 10.2.13
    • Labels:
    • Environment:
      Debian 9 fresh install
      mariadb from debian repos
      galera from debian repos
    • Sprint:
      10.2.13
    • Epic/Theme:

      Description

      Try to setup galera cluster from standalone mariadb server that has a few databases.

      From existing mariadb server use /var/lib/mysql as is
      on stock /etc/mysql/my.cnf
      add

      [galera]

      1. Mandatory settings
        wsrep_on=ON
        wsrep_provider=/usr/lib/galera/libgalera_smm.so
        wsrep_cluster_name="tam_cluster"
        wsrep_cluster_address="gcomm://ip1, ip2, ip5"
        wsrep_node_address="ip5"
        wsrep_node_name="node_5"
        wsrep_sst_method=rsync
        binlog_format=row
        default_storage_engine=InnoDB
        innodb_autoinc_lock_mode=2

      run: galera_new_cluster

      result: mysqld crashes

        Attachments

        1. jgnoss_first_pages_001.bin
          128 kB
        2. mdb_dbg.tgz
          302 kB
        3. my.cnf
          6 kB
        4. mysqld_debug.txt
          17 kB
        5. mysqld.debug_outputs.txt
          14 kB
        6. mysqld.trace
          9.42 MB
        7. mysqld.trace
          1.76 MB
        8. mysqld.trace
          1.82 MB
        9. mysqld.trace
          88 kB

          Activity

            People

            • Assignee:
              jplindst Jan Lindström
              Reporter:
              jgnoss Juergen Gnoss
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: