Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-10807

Advance-toolchain 10.0 for MariaDB-10.2

    Details

      Description

      advance-toolchain-10.0 got released today. Its based on gcc-6.2.1. I'd like to think there are advances in the compiler.

      Getting mariadb-10.2 packages built with this version would be a good time since its still pre-release.

      The yum packages for development and runtime AT8.0 and AT10.0 are installable at the same time without conflicts for the builders (RHEL/Centos7). This will be important if galera compiled against a different version.

      I've compiled the latest 10.2 code, debug and release against at10.0 and there are no compile or mtr (big-test included) problems. There are a couple of compiler warnings however nothing too significant.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dbart Daniel Bartholomew
                Reporter:
                danblack Daniel Black
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: