Uploaded image for project: 'MariaDB ColumnStore'
  1. MariaDB ColumnStore
  2. MCOL-998

MySQL replication is not replicating after installation



    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • 1.1.1
    • 1.1.2
    • installation
    • None
    • 2017-22


      Build tested: 1.0.12-1 Github source, 1.1.1-1 (rpm released QA today)

      commit a42eb6d1e74e44c9e8fd9bb8290e6ce7dbf909f5
      Merge: 2965fc8 6a14ced
      Author: David.Hall <david.hall@mariadb.com>
      Date: Tue Oct 3 10:12:33 2017 -0500

      Merge pull request #69 from mariadb-corporation/MCOL-940


      commit 28d26c89018faa3ec02fd49559b2fb53e6847e97
      Merge: a8414b9 5ab7538
      Author: Andrew Hutchings <andrew@linuxjedi.co.uk>
      Date: Thu Oct 26 20:22:27 2017 +0300

      Merge pull request #304 from mariadb-corporation/MCOL-979-1.0

      MCOL-979 getNullValueByType() should return string for all char types

      Stack configurations tested: 2pm combo, 2umpm

      Install the replication stack, verified server-id are correct, but databases are not replicated.

      Shutdownsystem and startsystem, system seemed to be normal. But mcsmysql on um2 failed due to missing mysql.sock file. I verified the mysqld process is running and supposed to be using the mysql.sock.

      [root@localhost ~]# mcsmysql
      ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/usr/local/mariadb/columnstore/mysql/lib/mysql/mysql.sock' (2)
      [root@localhost ~]# ps -ef |grep mysql
      root 5108 1 0 18:55 ? 00:00:00 /bin/sh /usr/local/mariadb/columnstore/mysql//bin/mysqld_safe --datadir=/usr/local/mariadb/columnstore/mysql/db --pid-file=/usr/local/mariadb/columnstore/mysql/db/localhost.localdomain.pid --ledir=/usr/local/mariadb/columnstore/mysql//bin
      mysql 5293 5108 99 18:55 ? 01:03:19 /usr/local/mariadb/columnstore/mysql//bin/mysqld --basedir=/usr/local/mariadb/columnstore/mysql/ --datadir=/usr/local/mariadb/columnstore/mysql/db --plugin-dir=/usr/local/mariadb/columnstore/mysql/lib/plugin --user=mysql --log-error=/usr/local/mariadb/columnstore/mysql/db/localhost.localdomain.err --pid-file=/usr/local/mariadb/columnstore/mysql/db/localhost.localdomain.pid --socket=/usr/local/mariadb/columnstore/mysql/lib/mysql/mysql.sock --port=3306
      root 15647 15538 0 19:59 pts/0 00:00:00 grep --color=auto mysql

      Another strange behavior I observed:

      Thinking that some processes may not have been started, I tried the enableMySQLRep commands while MySQLRep also has been enabled and got api errors:

      mcsadmin> enablemysqlreplication
      enablemysqlreplication Tue Oct 31 20:44:31 2017

      MariaDB ColumnStore Replication Feature is already enabled
      Do you want to proceed: (y or n) [n]: y

      Enter the 'User' Password or 'ssh' if configured with ssh-keys
      Please enter: vagrant

            • enableRep Failed : API Failure return in enableMySQLRep API
              mcsadmin> disablemysqlreplication
              disablemysqlreplication Tue Oct 31 20:47:12 2017
            • disableRep Failed : API Failure return in disableMySQLRep API
              mcsadmin> quit

      The command worked fine with MySQLRep is not enabled.




            dleeyh Daniel Lee (Inactive)
            dleeyh Daniel Lee (Inactive)
            0 Vote for this issue
            2 Start watching this issue



              Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.