Uploaded image for project: 'MariaDB ColumnStore'
  1. MariaDB ColumnStore
  2. MCOL-4949

Columnstore can not be removed in the non-interactive mode

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 6.2.1
    • Component/s: installation
    • Labels:
      None
    • Environment:
      Debian, Ubuntu

      Description

      1. install latest ES 10.4 - 10.4.22-14
      install command:

      export  DEBIAN_FRONTEND=noninteractive; sudo -E apt-get -q -o Dpkg::Options::=--force-confold -o Dpkg::Options::=--force-confdef -y --force-yes install mariadb-plugin-cracklib-password-check mariadb-plugin-columnstore mariadb-plugin-gssapi-server mariadb-plugin-gssapi-client mariadb-backup mariadb-plugin-spider mariadb-plugin-rocksdb libmariadb-dev libmariadb3 libmariadbclient18 libmysqlclient18 mariadb-client mariadb-common mariadb-server mysql-common
      

      2. Create a simple table, insert data, make a backup

      3. Try to remove server

      export  DEBIAN_FRONTEND=noninteractive; sudo -E apt-get -q -o Dpkg::Options::=--force-confold -o Dpkg::Options::=--force-confdef -y --force-yes remove  mariadb-server mariadb-columnstore*
      

      First, DEBIAN_FRONTEND=noninteractive is ignored - user needs to answer the "Checking for active transactions Do you want to proceed: (y or n) [n]" question

      second, if uninstall is done by script of config control tool (like Chef) the default answer is "no" and result is:

      dpkg -l | grep -i columnstore
      rc  mariadb-columnstore-platform           1:10.4.22.14+maria~buster     amd64        The platform binaries for MariaDB ColumnStore
      rc  mariadb-plugin-columnstore             1:10.4.22.14+maria~buster     amd64        MariaDB ColumnStore storage engine
      
      

      "mariadb-columnstore-libs" package removed, but another package - "mariadb-columnstore-platform" is still in the system (can it work without "mariadb-columnstore-libs" ?)

        Attachments

          Activity

            People

            Assignee:
            drrtuy Roman
            Reporter:
            tturenko Timofey Turenko
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.