Uploaded image for project: 'MariaDB ColumnStore'
  1. MariaDB ColumnStore
  2. MCOL-4083

Package based install without systemd of the latest develop does not work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.5.1
    • Component/s: installation
    • Labels:
      None

      Description

      Engine commit: 3cfbda3ad30cd9c759f5a24dd8be66586faa56d9 on develop
      Server commit: d84f9f3543722b2ee01fe54b6e91ee8fdd207c0a on bb-10.5-cs

      cmake was run without WITH_SYSTEMD=yes flag.

      While doing an RPM based package install, I get the following:

      Running transaction
        Installing : MariaDB-common-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    1/10 
        Installing : MariaDB-client-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    2/10 
        Installing : MariaDB-server-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    3/10 
        Installing : MariaDB-shared-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    4/10 
        Installing : MariaDB-columnstore-engine-10.5.4-1.el7.x86_64                                                                                                                                                                                                                        5/10 
      200616 19:59:22 mysqld_safe Logging to '/var/lib/mysql/tntnatbry-centos-2.err'.
      200616 19:59:22 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
      checking for engine columnstore...
      200616 19:59:25 mysqld_safe Logging to '/var/lib/mysql/tntnatbry-centos-2.err'.
      200616 19:59:25 mysqld_safe A mysqld process already exists
      columnstore doesn't exist
      warning: %post(MariaDB-columnstore-engine-10.5.4-1.el7.x86_64) scriptlet failed, exit status 1
      Non-fatal POSTIN scriptlet failure in rpm package MariaDB-columnstore-engine-10.5.4-1.el7.x86_64
        Installing : MariaDB-connect-engine-10.5.4-1.el7.x86_64                                                                                                                                                                                                                            6/10 
        Installing : MariaDB-gssapi-server-10.5.4-1.el7.x86_64                                                                                                                                                                                                                             7/10 
        Installing : MariaDB-test-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                      8/10 
        Installing : MariaDB-backup-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    9/10 
        Installing : MariaDB-devel-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    10/10 
      warning: %posttrans(MariaDB-server-10.5.4-1.el7.x86_64) scriptlet failed, exit status 5
      Non-fatal POSTTRANS scriptlet failure in rpm package MariaDB-server-10.5.4-1.el7.x86_64
        Verifying  : MariaDB-test-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                      1/10 
        Verifying  : MariaDB-common-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    2/10 
        Verifying  : MariaDB-backup-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    3/10 
        Verifying  : MariaDB-columnstore-engine-10.5.4-1.el7.x86_64                                                                                                                                                                                                                        4/10 
        Verifying  : MariaDB-client-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    5/10 
        Verifying  : MariaDB-devel-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                     6/10 
        Verifying  : MariaDB-server-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    7/10 
        Verifying  : MariaDB-connect-engine-10.5.4-1.el7.x86_64                                                                                                                                                                                                                            8/10 
        Verifying  : MariaDB-shared-10.5.4-1.el7.x86_64                                                                                                                                                                                                                                    9/10 
        Verifying  : MariaDB-gssapi-server-10.5.4-1.el7.x86_64 
      

        Attachments

          Activity

            People

            Assignee:
            jrojas Jose Rojas (Inactive)
            Reporter:
            tntnatbry Gagan Goel
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration