Uploaded image for project: 'MariaDB ColumnStore'
  1. MariaDB ColumnStore
  2. MCOL-3705

Combo installation with schema-sync does not create schema on pm2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 1.4.2
    • Fix Version/s: Icebox
    • Component/s: installation
    • Labels:
      None

      Description

      Build tested: 1.4.2-1 (Azure build 20191224.6)

      During postConfigure, I enabled schema-sync:

      NOTE: The MariaDB ColumnStore Schema Sync feature will replicate all of the
      schemas and InnoDB tables across the User Module nodes. This feature can be enabled
      or disabled, for example, if you wish to configure your own replication post installation. MariaDB ColumnStore Schema Sync feature, do you want to enable? [y,n] > y

      But when I create databases and tables on PM1, schemas are not synced to PM2. In the /etc/columnstore/Columnstore.xml file, <MySQLRep> is set to 'y'. I noticed that in the /etc/my.cnf.d/columnstore.cnf file, server-id is set to 1 and commented out on both PMs.

      I shutdown the system, setup server-id to 1 and 2 for PM1 and PM2, respectively. Restarted the system. Schema-sync was still not working.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              dleeyh Daniel Lee
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: