Uploaded image for project: 'MariaDB ColumnStore'
  1. MariaDB ColumnStore
  2. MCOL-3643

CentOS 7 - mariadb-columnstore-api-java installation fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.1
    • Fix Version/s: 1.4.2
    • Component/s: mcsapi
    • Labels:
      None
    • Environment:
      CentOS 7

      Description

      javamcsapi can't be installed from repository on CentOS 7.

      repo setup:

      [mariadb-columnstore-api]
      name=MariaDB ColumnStore API
      baseurl=http://34.238.186.75/repos/1.4.1-1/nightly/mariadb-columnstore-api/yum/centos/7/x86_64/
      gpgkey=https://downloads.mariadb.com/MariaDB/mariadb-columnstore/RPM-GPG-KEY-MariaDB-ColumnStore
      gpgcheck=1
      

      installation:

      [root@um1 jens]# yum install mariadb-columnstore-api*
      Loaded plugins: fastestmirror
      Loading mirror speeds from cached hostfile
       * base: ftp.hosteurope.de
       * epel: mirror.serverion.com
       * extras: mirror.alpha-labs.net
       * updates: ftp.rz.uni-frankfurt.de
      Package mariadb-columnstore-api-python3-1.4.0-1.x86_64 already installed and latest version
      Package mariadb-columnstore-api-cpp-1.4.0-1.x86_64 already installed and latest version
      Resolving Dependencies
      --> Running transaction check
      ---> Package mariadb-columnstore-api-cpp-devel.x86_64 0:1.4.0-1 will be installed
      ---> Package mariadb-columnstore-api-java.x86_64 0:1.4.0-1 will be installed
      --> Processing Dependency: libjavamcsapi.so()(64bit) for package: mariadb-columnstore-api-java-1.4.0-1.x86_64
      ---> Package mariadb-columnstore-api-pyspark.x86_64 0:1.4.0-1 will be installed
      ---> Package mariadb-columnstore-api-pyspark3.x86_64 0:1.4.0-1 will be installed
      ---> Package mariadb-columnstore-api-python.x86_64 0:1.4.0-1 will be installed
      ---> Package mariadb-columnstore-api-spark.x86_64 0:1.4.0-1 will be installed
      --> Finished Dependency Resolution
      Error: Package: mariadb-columnstore-api-java-1.4.0-1.x86_64 (mariadb-columnstore-api)
                 Requires: libjavamcsapi.so()(64bit)
       You could try using --skip-broken to work around the problem
       You could try running: rpm -Va --nofiles --nodigest
      [root@um1 jens]# yum install mariadb-columnstore-api-java
      Loaded plugins: fastestmirror
      Loading mirror speeds from cached hostfile
       * base: ftp.hosteurope.de
       * epel: mirror.serverion.com
       * extras: mirror.alpha-labs.net
       * updates: ftp.rz.uni-frankfurt.de
      Resolving Dependencies
      --> Running transaction check
      ---> Package mariadb-columnstore-api-java.x86_64 0:1.4.0-1 will be installed
      --> Processing Dependency: libjavamcsapi.so()(64bit) for package: mariadb-columnstore-api-java-1.4.0-1.x86_64
      --> Finished Dependency Resolution
      Error: Package: mariadb-columnstore-api-java-1.4.0-1.x86_64 (mariadb-columnstore-api)
                 Requires: libjavamcsapi.so()(64bit)
       You could try using --skip-broken to work around the problem
       You could try running: rpm -Va --nofiles --nodigest
      [root@um1 jens]#
      

      I assume that there was an old installation of javamcsapi on buildbot which the created package is referring to. But this is up to investigation.

        Attachments

          Activity

            People

            Assignee:
            LinuxJedi Andrew Hutchings (Inactive)
            Reporter:
            jens.rowekamp Jens Röwekamp (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.