Uploaded image for project: 'MariaDB Connector/Python'
  1. MariaDB Connector/Python
  2. CONPY-85

MariaDB Connector/Python requires MariaDB Connector/C >= 3.1.3, found version 3.1.10

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.1
    • Component/s: Installation
    • Labels:
      None
    • Environment:
      Linux Ubuntu 18.04 lts (32bit) / Mariadb 10.4.13

      Description

      *pip3 install mariadb failed *

      after installing mariadb connector/c from source (see below) the pip3 install mariadb failed due to MariaDB Connector/Python requires MariaDB Connector/C >= 3.1.3, found version 3.1.10

      The >=3.1.3 should not occur if 3.1.10 is found

      mariadb connector install script/log:

      rm -r mariadb-connector-c/
      rm -r build
      git clone https://github.com/MariaDB/mariadb-connector-c.git
      mkdir build
      cd build
      cmake ../mariadb-connector-c/ -DCMAKE_INSTALL_PREFIX=/usr/local
      make
      make install

      Install the project...
      – Install configuration: "RelWithDebInfo"
      – Installing: /usr/local/lib/mariadb/plugin/dialog.so
      – Installing: /usr/local/lib/mariadb/plugin/client_ed25519.so
      – Installing: /usr/local/lib/mariadb/plugin/caching_sha2_password.so
      – Installing: /usr/local/lib/mariadb/plugin/sha256_password.so
      – Installing: /usr/local/lib/mariadb/plugin/mysql_clear_password.so
      – Installing: /usr/local/include/mariadb/mariadb_com.h
      – Installing: /usr/local/include/mariadb/mysql.h
      – Installing: /usr/local/include/mariadb/mariadb_stmt.h
      – Installing: /usr/local/include/mariadb/ma_pvio.h
      – Installing: /usr/local/include/mariadb/ma_tls.h
      – Installing: /usr/local/include/mariadb/mariadb_version.h
      – Installing: /usr/local/include/mariadb/ma_list.h
      – Installing: /usr/local/include/mariadb/errmsg.h
      – Installing: /usr/local/include/mariadb/mariadb_dyncol.h
      – Installing: /usr/local/include/mariadb/mariadb_ctype.h
      – Installing: /usr/local/include/mariadb/mariadb_rpl.h
      – Installing: /usr/local/include/mariadb/mysqld_error.h
      – Installing: /usr/local/include/mariadb/mysql/client_plugin.h
      – Installing: /usr/local/include/mariadb/mysql/plugin_auth_common.h
      – Installing: /usr/local/include/mariadb/mysql/plugin_auth.h
      – Installing: /usr/local/include/mariadb/mariadb/ma_io.h
      – Installing: /usr/local/lib/mariadb/libmariadbclient.a
      – Installing: /usr/local/lib/mariadb/libmariadb.so.3
      – Installing: /usr/local/lib/mariadb/libmariadb.so
      – Installing: /usr/local/bin/mariadb_config
      – Installing: /usr/local/lib/pkgconfig/libmariadb.pc

      pip3 install nmariadb log

      Collecting mariadb
      Downloading https://files.pythonhosted.org/packages/8f/c9/7050899dc1066409a17e1147d3afe1b078e582afdb755c6d3cb9c9a5c3ab/mariadb-1.0.0.tar.gz (78kB)
      100% |████████████████████████████████| 81kB 2.6MB/s
      Complete output from command python setup.py egg_info:
      10.4.3
      MariaDB Connector/Python requires MariaDB Connector/C >= 3.1.3, found version 3.1.10

      ----------------------------------------
      Command "python setup.py egg_info" failed with error code 2 in /tmp/pip-build-3j3fbw16/mariadb/

        Attachments

          Activity

            People

            Assignee:
            georg Georg Richter
            Reporter:
            vincent.lemoine@iwa-consult.nl V H Lemoine
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: