Uploaded image for project: 'MariaDB MaxScale'
  1. MariaDB MaxScale
  2. MXS-6859

Certain types of network errors should trigger an immediate server DNS lookup

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • 24.02.10, 25.01.7, 25.10.3
    • 24.02.11, 25.01.8, 25.10.4
    • Core
    • None

    Description

      Whenever a DNS name changes and it starts to point to a different IP (e.g. with kubernetes based setups), the old network might not be reachable. In these cases, triggering an immediate DNS refresh would make the hostname converge faster onto the new IP. This should only be done if there's been no refreshes already triggered since the last update interval.

      Attachments

        Activity

          People

            markus makela markus makela
            markus makela markus makela
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0d
                0d
                Logged:
                Time Spent - 1d
                1d

                Git Integration

                  Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.