Details
-
Task
-
Status: In Review (View Workflow)
-
Major
-
Resolution: Unresolved
-
None
-
None
-
None
-
MXS-SPRINT-278, MXS-SPRINT-279
Description
We need to confirm and finalize the exact log/error messaging shown to
customers at each stage of the license lifecycle
MESSAGING
Note: 0 = end of grace period
- Cadence:
- Every 7 days from 180 days before end of grace period
- Daily during the final 2 weeks of contract ( 110 - 90 days left )
- Confirm severity/day mapping
(assuming default 90 day grace period means
90 days left = end of contract
0 days = end of grace period) - Notice — 180 days
- Warning — 60 days
- Error — 90 days ( end contract )
- Critical — 14 days
- Emergency — 0 days ( end of grace period )
- Notice/ Warning Message format (once a week?):
"Your license is expiring in {N}days, please reach out to your account team."
- Error — longer, one-time message:
"Your license is now expired, and has entered into a {X}-day grace
period. During this time you can continue normal operations while you
work to get your new license. After this grace period, you will not be
allowed to restart MaxScale. If you have not already, it's important to
reach out to MariaDB at sales@mariadb.com."
- Error daily - shorter, recurring message:
"Your license has expired. You will not be able to restart MaxScale in
{X}days. Immediately contact MariaDB at sales@mariadb.com."
- Critical - log every x hours ?
- Emergency - every hour?
"Your grace period has ended. You will not be allowed to restart
MaxScale until you load a new valid license. Please reach out to
sales@mariadb.com."