Uploaded image for project: 'MariaDB MaxScale'
  1. MariaDB MaxScale
  2. MXS-6577

Transaction reply works only with explicit transaction

    XMLWordPrintable

Details

    • New Feature
    • Status: Open (View Workflow)
    • Critical
    • Resolution: Unresolved
    • 25.10.0
    • None
    • readwritesplit
    • None

    Description

      We have been debug a issue with customer, where during the master switch with transaction_reply enable, the customer keep facing application error cause implicit transaction ( autocommit =on), try to run a INSERT, and this insert fail, cause the master become in read-only.
      The read-only indeed is part of the switch process, what we would have expected is that the explicit transaction, got hold by maxscale, until the new master is promoted and then fire the INSERT there, or at least untile the transaction_reply timeout is not reached.

      Attachments

        Issue Links

          Activity

            People

              markus makela markus makela
              massimo.disaro Massimo
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:

                Git Integration

                  Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.