Uploaded image for project: 'MariaDB MaxScale'
  1. MariaDB MaxScale
  2. MXS-415

MaxScale 1.2.1 crashed with Signal 6 and 11

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.2.1
    • Fix Version/s: 1.3.0
    • Component/s: readconnroute
    • Labels:
      None
    • Environment:
      Debian 7.9, VM under KVM, 8 vCPUs/8GB RAM (designed sql LB type) - deb package involved : maxscale-1.2.1-1.deb_wheezy.x86_64.deb

      Description

      Hello guys,

      At a quick search the issue seems very similar to MXS-337.

      The LB is in production for approx 2 weeks, in which there were no outages/issues (nor to mysql or maxscale side) due to it's behalf. The system VM is running LB solo, no other services involved or running to it, as it has the following usage:

      07:17:41 up 6 days, 3:59, 1 user, load average: 0.07, 0.05, 0.05

      total used free shared buffers cached
      Mem: 8007 459 7548 0 126 154
      -/+ buffers/cache: 177 7829
      Swap: 879 0 879

      The LB is configured to connected to 4 nodes running galera 3.12.1.wheezy and percona xtradb cluster 5.6.25-25.12-1.wheezy both amd64.

      Any clues why did the service died ?
      I will be monitoring to see if this issue will be back.

      Update: on less than 24 hours the issue repeats again. I have attached the log with the latest backtrace in addition to the initial one.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              markus makela markus makela
              Reporter:
              avladulescu Alex Vladulescu
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: