Uploaded image for project: 'MariaDB MaxScale'
  1. MariaDB MaxScale
  2. MXS-1590

PAM authentication plugin shared libraries missing in binary packages

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.1
    • Component/s: Packaging
    • Labels:
      None
    • Environment:
      Linux (tested on Ubuntu Xenial and CentOS 7)
    • Sprint:
      MXS-SPRINT-50, MXS-SPRINT-51

      Description

      Trying to use the new PAM functionality MaxScale startup failed with:

      var/log/maxscale/maxscale.log:2018-01-02 10:15:34 error : Unable to find library for module: PAMBackendAuth. Module dir: /usr/local/maxscale/lib/maxscale

      Checking strace output it shows:

      12994 access("/usr/local/maxscale/lib/maxscale/libPAMBackendAuth.so", F_OK) = -1 ENOENT (No such file or directory)

      I checked the Ubuntu Xenial binary tarball, the .deb package and the CentOS7 RPM, neither seem to have the necessary plugin library files bundled

        Attachments

          Activity

            People

            Assignee:
            tturenko Timofey Turenko
            Reporter:
            hholzgra Hartmut Holzgraefe
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.