Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-9817

Cannot install galera on openSUSE 13.2 (libboost 1.53 dependency)

    XMLWordPrintable

    Details

      Description

      rpm -qa | grep -i boost                                                                                                    
      boost-license1_54_0-1.54.0-10.1.3.noarch
      libboost_system1_54_0-1.54.0-10.1.3.x86_64
      libboost_thread1_54_0-1.54.0-10.1.3.x86_64
      libboost_program_options1_54_0-1.54.0-10.1.3.x86_64
      elenst@linux-4b4d:~> sudo zypper install galera
      Loading repository data...
      Reading installed packages...
      Resolving package dependencies...
       
      Problem: nothing provides libboost_program_options.so.1.53.0()(64bit) needed by galera-25.3.15-1.sles13.suse13.1.x86_64
       Solution 1: do not install galera-25.3.15-1.sles13.suse13.1.x86_64
       Solution 2: break galera-25.3.15-1.sles13.suse13.1.x86_64 by ignoring some of its dependencies
      

      Maybe it's so for Galera from repo of previous versions, I didn't check.

        Attachments

          Activity

            People

            Assignee:
            sachin.setiya.007 Sachin Setiya (Inactive)
            Reporter:
            elenst Elena Stepanova
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.