Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-9082

Debian: mysql_install_db is called on upgrade

    XMLWordPrintable

    Details

    • Sprint:
      10.1.9-2

      Description

      A comment in debian/mariadb-server-10.1.postinst says: "can safely run on upgrades with existing databases". While this is true there're a few reasons not to do that:

      • it increases installation time (it has to run rather heavy mysqld multiple times)
      • as well as it increases mysqld downtime
      • it may fail if database has some plugin specific configs (see MDEV-8437)
      • there should be no need to run this script on upgrade: they should be handled by mysql_upgrade to
      • RPM postin doesn't call it if database directory exists

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              svoj Sergey Vojtovich
              Reporter:
              svoj Sergey Vojtovich
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Git Integration