Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-6633

Remove magic dependencies for InnoDB compression methods

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 10.1.0
    • Fix Version/s: 10.1.3
    • Component/s: Packaging
    • Labels:
      None

      Description

      Magic dependencies are a not a good thing.
      If a library dependency is required, it should be checked for and error out if the system has it missing.
      If it is optional, a cmake option should be made to skip over it if disabled, but error out if enabled and missing.
      From a package manager's point of view, creating things that are optional if it simply exists becomes an issue if that library is ever removed from the system.

      Please create options for each compression type if they are able to be disabled.

      Suggestion for cmake option names: WITH_INNODB_{BZIP2,LZMA,LZO,LZ4}

        Attachments

          Activity

            People

            Assignee:
            jplindst Jan Lindström
            Reporter:
            grknight Brian Evans
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration