Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-6542

debian binary server packages depend on client library

    XMLWordPrintable

    Details

      Description

      To work around an issue with binary incompatibility witht he mariadbclient libraries, O tried to install the libmysqlclient libraries.

      However, the prebuilt debian packages for mariadb make this impossible, as the server explicitly depends on the mariadbclient package, which conflicts with the libmysqlclient.

      I think only the metapackage should depend on both server and client, otherwise it is impossible to install the mysql client (required by many programs) alongside the mariadb server.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              otto Otto Kekäläinen
              Reporter:
              schmorp Marc Lehmann
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Git Integration

                  Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.