Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-5825

Assertion `! is_set() || m_can_overwrite_status' fails in Diagnostics_area::set_error_status on executing rpl.rpl_parallel test

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 10.0.9
    • Fix Version/s: 10.0.10
    • Component/s: None
    • Labels:
      None

      Description

      I run the MTR test repeatedly in parallel mode:

      perl ./mtr rpl.rpl_parallel --repeat=1000 --parallel=2

      After some time, a slave goes down with the assertion failure:

      #5  0x00007f04b9f38b8b in __GI_abort () at abort.c:91
      #6  0x00007f04b9f2e0ee in __assert_fail_base (fmt=<optimized out>, assertion=0xf235d0 "! is_set() || m_can_overwrite_status", file=0xf234c0 "10.0/sql/sql_error.cc", line=<optimized out>, function=<optimized out>) at assert.c:94
      #7  0x00007f04b9f2e192 in __GI___assert_fail (assertion=0xf235d0 "! is_set() || m_can_overwrite_status", file=0xf234c0 "10.0/sql/sql_error.cc", line=473, function=0xf239e0 "void Diagnostics_area::set_error_status(uint, const char*, const char*, const Sql_condition*)") at assert.c:103
      #8  0x00000000006344a9 in Diagnostics_area::set_error_status (this=0x7f04b1f430c8, sql_errno=1964, message=0x7f04bbc489f0 "Commit failed due to failure of an earlier commit on which this one depends", sqlstate=0xf39c9f "HY000", error_condition=0x0) at 10.0/sql/sql_error.cc:473
      #9  0x000000000061bb39 in THD::raise_condition (this=0x7f04b1f3e070, sql_errno=1964, sqlstate=0xf39c9f "HY000", level=Sql_condition::WARN_LEVEL_ERROR, msg=0x7f04bbc489f0 "Commit failed due to failure of an earlier commit on which this one depends") at 10.0/sql/sql_class.cc:1258
      #10 0x000000000059b26f in my_message_sql (error=1964, str=0x7f04bbc489f0 "Commit failed due to failure of an earlier commit on which this one depends", MyFlags=0) at 10.0/sql/mysqld.cc:3425
      #11 0x0000000000e2c168 in my_error (nr=1964, MyFlags=0) at 10.0/mysys/my_error.c:125
      #12 0x00000000007db383 in wait_for_commit::wait_for_prior_commit (this=0x7f04a8a72030, thd=0x7f04b1f3e070) at 10.0/sql/sql_class.h:1706
      #13 0x00000000007db3f0 in THD::wait_for_prior_commit (this=0x7f04b1f3e070) at 10.0/sql/sql_class.h:3619
      #14 0x00000000007d8b52 in handle_rpl_parallel_thread (arg=0x7f04a84c1b40) at 10.0/sql/rpl_parallel.cc:521
      #15 0x0000000000deb15b in pfs_spawn_thread (arg=0x7f04a86a3d10) at 10.0/storage/perfschema/pfs.cc:1853
      #16 0x00007f04bb0ffe9a in start_thread (arg=0x7f04bbc49700) at pthread_create.c:308
      #17 0x00007f04b9ff33fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112

      Stack trace from:

      revision-id: svoj@mariadb.org-20140307074306-blf3begv8ee0tb5j
      date: 2014-03-07 11:43:06 +0400
      build-date: 2014-03-11 16:15:11 +0400
      revno: 4045
      branch-nick: 10.0
      built as: cmake . -DCMAKE_BUILD_TYPE=Debug && make

      It happens on two machines where I tried, but on some reason only in --parallel mode.

        Attachments

          Activity

            People

            • Assignee:
              knielsen Kristian Nielsen
              Reporter:
              elenst Elena Stepanova
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: