Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-4749

php fails to build when version is >=5.6.11 and MYSQL_OPT_CAN_HANDLE_EXPIRED_PASSWORDS is not present

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 10.0.3
    • Fix Version/s: 10.0.4
    • Component/s: None
    • Labels:
      None
    • Environment:
      Gentoo Linux x86_64 Source build

      Description

      When PHP is built against MariaDB 10.0 libmysqlclient, it fails to complete as it is expecting MYSQL_OPT_CAN_HANDLE_EXPIRED_PASSWORDS.

      From php:

      #if MYSQL_VERSION_ID >= 50611 || defined(MYSQLI_USE_MYSQLND)
              REGISTER_LONG_CONSTANT("MYSQLI_OPT_CAN_HANDLE_EXPIRED_PASSWORDS", MYSQL_OPT_CAN_HANDLE_EXPIRED_PASSWORDS, CONST_CS | CONST_PERSISTENT);
      #endif

      Build log snippet:

      /var/tmp/portage/dev-lang/php-5.4.13/work/sapis-build/cli/ext/mysqli/mysqli_api.c: In function 'mysqli_options_get_option_zval_type':
      /var/tmp/portage/dev-lang/php-5.4.13/work/sapis-build/cli/ext/mysqli/mysqli_api.c:1676:8: error: 'MYSQL_OPT_CAN_HANDLE_EXPIRED_PASSWORDS' undeclared (first use in this function)

        Attachments

          Activity

            People

            Assignee:
            serg Sergei Golubchik
            Reporter:
            grknight Brian Evans
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: