Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-41139

mariabackup --prepare fails if encryption is used, and gives no error code.

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Major
    • Resolution: Unresolved
    • 11.4, 11.8
    • None
    • mariabackup
    • None

    Description

      I’m taking a backup of a publicly accessible directory but I’m getting the following error while preparing the backup:

      Warning: World-writable config file '/opt/mysql/backup/20260823/backup-my.cnf' is ignored
      Warning: World-writable config file '/opt/mysql/backup/20260823/backup-my.cnf' is ignored
      mariadb-backup based on MariaDB server 11.4.12-MariaDB Linux (x86_64)
      [00] 2026-08-23 12:00:40 cd to /opt/mysql/backup/20260823/
      [00] 2026-08-23 12:00:40 open files limit requested 0, set to 1048576
      [00] 2026-08-23 12:00:40 Renaming ./mysql/mariadb_backup_history.new to ./mysql/mariadb_backup_history.ibd
       
      [00] 2026-08-23 12:00:40 Loading encryption plugin from file_key_management=file_key_management
      [00] 2026-08-23 12:00:40 Loading encryption plugin
      [00] 2026-08-23 12:00:40         Encryption plugin parameter :  'mariadb-backup'
      [00] 2026-08-23 12:00:40         Encryption plugin parameter :  '--prepare'
      [00] 2026-08-23 12:00:40         Encryption plugin parameter :  '--target-dir=/opt/mysql/backup/20260823'
      mariadb-backup: Can't open shared library '/file_key_management.so' (errno: 2, cannot open shared object file: No such file or directory)
      2026-08-23 12:00:40 0 [ERROR] Couldn't load plugin 'file_key_management' from 'file_key_management.so'.
      [00] 2026-08-23 12:00:40 This target seems to be not prepared yet.
      [00] 2026-08-23 12:00:40 mariabackup: using the following InnoDB configuration for recovery:
      ...
      ..
      2026-08-23 12:00:44 0 [Note] InnoDB: Starting shutdown...
      recovered pages: 0% 26% 41% 62% 84% 100% (0.1 seconds); tables to flush: 2 1 0 (0.0 seconds);
      [00] 2026-08-23 12:00:44 completed OK!
      Sun Aug 23 12:00:44 PM CEST 2026
      Return code mariabackup prepare: 0
      

      Two primary concerns :

      1. The prepare process should not generate the warning "Warning: World-writable config file '/opt/mysql/backup/20260823/backup-my.cnf' " is ignored. If mariabackup permits taking a backup in a world-writable directory (777), it should consistently allow the prepare phase to run against that same configuration file without ignoring it.

      2. In the event of an error during execution, the utility should exit with a non-zero return code (1) rather than reporting a success status (0).

      Attachments

        Activity

          People

            thiru Thirunarayanan Balathandayuthapani
            niljoshi Nilnandan Joshi
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0d
                0d
                Logged:
                Time Spent - 0.25d
                0.25d

                Git Integration

                  Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.