Details
-
Bug
-
Status: Open (View Workflow)
-
Major
-
Resolution: Unresolved
-
11.8.8
-
None
Description
MariaDB [(none)]> SELECT LOAD_FILE('/etc/shadow');
|
+--------------------------+
|
| LOAD_FILE('/etc/shadow') |
|
+--------------------------+
|
| NULL |
|
+--------------------------+
|
1 row in set (0.001 sec)
|
Expected result - a warning produces on permission failure like LOAD DATA INFILE
MariaDB [test]> LOAD DATA INFILE '/etc/shadow' INTO TABLE shadow_test FIELDS TERMINATED BY ':' LINES TERMINATED BY '\n' (usernam
|
e, passw
|
ERROR 13 (HY000): Can't get stat of '/etc/shadow' (Errcode: 13 "Permission denied")
|