Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-41000

LOAD_DATA fails to warn/errror if insufficient permissions on file

    XMLWordPrintable

Details

    • Bug
    • Status: Open (View Workflow)
    • Major
    • Resolution: Unresolved
    • 11.8.8
    • 11.8
    • Server
    • None

    Description

      MariaDB [(none)]> SELECT LOAD_FILE('/etc/shadow');
      +--------------------------+
      | LOAD_FILE('/etc/shadow') |
      +--------------------------+
      | NULL                     |
      +--------------------------+
      1 row in set (0.001 sec)
      

      Expected result - a warning produces on permission failure like LOAD DATA INFILE

      MariaDB [test]> LOAD DATA INFILE '/etc/shadow' INTO TABLE shadow_test FIELDS TERMINATED BY ':' LINES TERMINATED BY '\n' (usernam
      e, passw
      ERROR 13 (HY000): Can't get stat of '/etc/shadow' (Errcode: 13 "Permission denied")
      

      Attachments

        Activity

          People

            Unassigned Unassigned
            danblack Daniel Black
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:

              Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.