Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-30322

Installing MariaDB 10.5 or older 10.4/10.3/10.2 from mariadb.org for Debian Sid repositories fail due to removal of OpenSSL 1.1



    • Bug
    • Status: Open (View Workflow)
    • Minor
    • Resolution: Unresolved
    • None
    • None
    • None
    • None


      Ubuntu 22.04 released with OpenSSL version 3.0 only (MDEV-28397). The next Debian release will also release with OpenSSL version 3 only, and thus older OpenSSL 1.1 has recently been removed from Debian Sid (unstable) repositories.

      Trying to install latest any MariaDB 10.5.x from MariaDB.org repositories for Debian Sid will fail with error messge:

      $ echo "deb https://archive.mariadb.org/mariadb-10.5/repo/debian ${RELEASE} main" > /etc/apt/sources.list.d/mariadb.list
      $ apt-get update -qq
      $ apt-get install -y mariadb-server-10.5
      Reading package lists...
      Building dependency tree...
      Reading state information...
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:
      The following packages have unmet dependencies:
       mariadb-server-10.5 : Depends: mariadb-client-10.5 (>= 1:10.5.13+maria~sid) but it is not going to be installed
                             Depends: mariadb-server-core-10.5 (>= 1:10.5.13+maria~sid) but it is not going to be installed
                             Depends: libssl1.1 (>= 1.1.1) but it is not installable
                             Recommends: libhtml-template-perl but it is not going to be installed
      E: Unable to correct problems, you have held broken packages.

      There are two possible solutions:

      1. Backport OpenSSL 3.0 support for 10.2/3/4/5 and rebuild it for Debian Sid to depend on OpenSSL 3.0 instead of older 1.1. This was done for 10.6+ in MDEV-28133 and https://github.com/MariaDB/server/pull/2036 but I don't think changing changing the OpenSSL library major version in a stable release is feasible.

      2. Stop providing 10.2/3/4/5 for Debian Sid. Actually I think this is already the case, as MariaDB 10.6 exists in Debian officially no older versions are built or provided for Debian Sid anymore. Any CI systems that use Debian Sid for 10.2/3/4/5 upgrade testing will just start to use Bullseye instead (e.g. https://salsa.debian.org/mariadb-team/mariadb-server/-/pipelines/477568).

      Marking priority low. The main motivation to file this bug report is to have the error message somewhere that people can stumble upon it and learn what it the known root cause for it.

      Conclusion: If you came across this bug report because you are trying to install MariaDB 10.2/3/4/5 on Debian Sid - just stop doing it, it is no longer supported as Debian Sid moved along to new OpenSSL generation.

      Workaround: If you can't stop using on Debian Sid, you can manually install the old library with:

      curl -O http://ftp.de.debian.org/debian/pool/main/o/openssl/libssl1.1_1.1.1o-1_amd64.deb
      apt-get install --no-install-recommends --yes ./libssl1.1_1.1.1o-1_amd64.deb


        Issue Links



              Unassigned Unassigned
              otto Otto Kekäläinen
              0 Vote for this issue
              5 Start watching this issue



                Git Integration

                  Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.