Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-27597

Columnstore package in CS 10.6.5 release can not be installed on SLES 12 due to lz4 dependency

    XMLWordPrintable

    Details

      Description

      Attempt to install MariaDB-columnstore-engine-10.6.5 from https://dlm.mariadb.com/repo/mariadb-server/10.6.5/yum/sles/12/x86_64
      on SLES 12.5 :

      https://mdbe-buildbot.mariadb.net/#/builders/45/builds/2/steps/29/logs/stdio

      Problem: nothing provides liblz4.so.1.7()(64bit) needed by MariaDB-columnstore-engine-10.6.5_6.2.1-1.x86_64
       Solution 1: do not install MariaDB-columnstore-engine-10.6.5_6.2.1-1.x86_64
       Solution 2: break MariaDB-columnstore-engine-10.6.5_6.2.1-1.x86_64 by ignoring some of its dependencies
      
      

      SLES 12 has:

      Information for package liblz4-1:
      ---------------------------------
      Repository     : SLE-SDK12-SP5-Updates                      
      Name           : liblz4-1                                   
      Version        : 1.8.0-3.3.1  
      

        Attachments

          Activity

            People

            Assignee:
            tturenko Timofey Turenko
            Reporter:
            tturenko Timofey Turenko
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.