Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-27425

"mariadb-secure-installation --print-defaults" / "mysql_secure_installation --print-defaults" doesn't work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 10.5.12
    • Fix Version/s: N/A
    • Labels:
      None
    • Environment:
      Debian 11.2 bullseye amd64

      Description

      https://mariadb.com/kb/en/mysql_secure_installation/ (permalink) mentions twice the --print-defaults option for command mariadb-secure-installation (or mysql_secure_installation):

      --print-defaults Print the program argument list and exit.

      But running mariadb-secure-installation --print-defaults (or mysql_secure_installation --print-defaults) doesn't show the argument list, but rather seems to behave just like running mariadb-secure-installation (or mysql_secure_installation) without any options.

      It would be helpful to have an option -print-defaults to see with which options mariadb-secure-installation sets up the secure installation.

      Detailed environment:

      Server version: 10.5.12-MariaDB-0+deb11u1 Debian 11
       
      running on a Debian 11.2
      # uname -a
      Linux foo 5.10.0-10-amd64 #1 SMP Debian 5.10.84-1 (2021-12-08) x86_64 GNU/Linux
       
      # apt list mariadb*
      mariadb-backup/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-client-10.5/stable,stable,now 1:10.5.12-0+deb11u1 amd64 [installed,automatic]
      mariadb-client-core-10.5/stable,stable,now 1:10.5.12-0+deb11u1 amd64 [installed,automatic]
      mariadb-client/stable,stable,now 1:10.5.12-0+deb11u1 all [installed]
      mariadb-common/stable,stable,now 1:10.5.12-0+deb11u1 all [installed,automatic]
      mariadb-plugin-connect/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-plugin-cracklib-password-check/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-plugin-gssapi-client/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-plugin-gssapi-server/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-plugin-mroonga/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-plugin-oqgraph/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-plugin-rocksdb/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-plugin-s3/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-plugin-spider/stable,stable 1:10.5.12-0+deb11u1 amd64
      mariadb-server-10.5/stable,stable,now 1:10.5.12-0+deb11u1 amd64 [installed,automatic]
      mariadb-server-core-10.5/stable,stable,now 1:10.5.12-0+deb11u1 amd64 [installed,automatic]
      mariadb-server/stable,stable,now 1:10.5.12-0+deb11u1 all [installed]
      mariadb-test-data/stable,stable 1:10.5.12-0+deb11u1 all
      mariadb-test/stable,stable 1:10.5.12-0+deb11u1 amd64
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            foo Gerrit Hübbers
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.