Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-26970

MariaDB InnoDB Plugin Failure - NUC/CIFS mounts



    • Bug
    • Status: Confirmed (View Workflow)
    • Major
    • Resolution: Unresolved
    • 10.5
    • 10.5
    • Docker


      I'm trying to deploy a new Photoprism docker instance, and as part of the docker-compose it sets up a MariaDB instance.

      I seem to be getting consistent errors pertaining to Assertion Errors and Corrupted pages (see below).

      My setup is as follows: Windows 10 Pro -> Virtualbox 6.1 -> Ubuntu Server 20.04 LTS -> Docker 20.10.10 -> MariaDB. The CPU is an Intel i5-9500T. The ubuntu VM is allocated 2 CPUs and 6GB RAM. I have also tried to set up Docker on an Ubuntu 20.04 server installed directly on an Intel N3850-powered NUC, with the same results. In the Virtualbox setup, the drives are mounted via the Virtualbox Shared Folder feature. In the NUC setup, the drives are mounted as SMB3.0 network shares.

      The issue seems to be unique to the situation where the database needs to be created on a remote network drive. This drive is mounted in a USB caddy and connected to the Windows 10 Pro computer via USB 3.0. The file system is NTFS. Other docker containers on both Virtualbox and the NUC are able to read/write data to these shared drives without any issue.

      I've tried versions 10.5, 10.6 and Latest of mariaDB, with the same behaviour observed in all three.

      As suggested in the Discussions page, I tried innodb_use_native_aio=0 in the command but this didn't seem to have any effect.

      I've included the output from the commands suggested in the discussion page (before the innodb_use_native_aio=0 was applied). There was no output after the "thread apply all bt full" command. The testdir folder also had no content. Not sure if this is what was expected.

      Happy to help in whatever way I can


        Issue Links



              Unassigned Unassigned
              captainkev Kevin Wilson
              1 Vote for this issue
              5 Start watching this issue



                Git Integration

                  Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.