Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-25625

Test sys_vars.wsrep_on_without_provider fails: mysqltest: At line 8: query 'SET GLOBAL wsrep_on=ON' failed with wrong errno 1193: 'Unknown system variable 'wsrep_on'', instead of 1210...

    XMLWordPrintable

    Details

      Description

      $ ./mtr sys_vars.wsrep_on_without_provider
      Logging: /var/tmp/portage/dev-db/mariadb-10.5.10/work/mysql/mysql-test/mysql-test-run.pl  sys_vars.wsrep_on_without_provider
      vardir: /var/tmp/portage/dev-db/mariadb-10.5.10/work/mariadb-10.5.10_build/mysql-test/var
      Removing old var directory...
      Creating var directory '/var/tmp/portage/dev-db/mariadb-10.5.10/work/mariadb-10.5.10_build/mysql-test/var'...
      Checking supported features...
      MariaDB Version 10.5.10-MariaDB
       - SSL connections supported
      Collecting tests...
      Installing system database...
       
      ==============================================================================
       
      TEST                                      RESULT   TIME (ms) or COMMENT
      --------------------------------------------------------------------------
       
      worker[1] Using MTR_BUILD_THREAD 300, with reserved ports 16000..16019
      sys_vars.wsrep_on_without_provider       [ fail ]
              Test ended at 2021-05-09 12:12:52
       
      CURRENT_TEST: sys_vars.wsrep_on_without_provider
      mysqltest: At line 8: query 'SET GLOBAL wsrep_on=ON' failed with wrong errno 1193: 'Unknown system variable 'wsrep_on'', instead of 1210...
       
      The result from queries just before the failure was:
      SET GLOBAL wsrep_on=ON;
       
       - saving '/var/tmp/portage/dev-db/mariadb-10.5.10/work/mariadb-10.5.10_build/mysql-test/var/log/sys_vars.wsrep_on_without_provider/' to '/var/tmp/portage/dev-db/mariadb-10.5.10/work/mariadb-10.5.10_build/mysql-test/var/log/sys_vars.wsrep_on_without_provider/'
      --------------------------------------------------------------------------
      The servers were restarted 0 times
      Spent 0.000 of 1 seconds executing testcases
       
      Failure: Failed 1/1 tests, 0.00% were successful.
       
      Failing test(s): sys_vars.wsrep_on_without_provider
      

        Attachments

          Activity

            People

            Assignee:
            serg Sergei Golubchik
            Reporter:
            whissi Thomas Deutschmann
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Git Integration

                Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.