Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-24292

support semi-independent versioning for sub-packages

    XMLWordPrintable

    Details

      Description

      Certain components of a server release have separate version numbers. This confuses users because it's generally not clear what component version corresponds to what server version. Currently it is solved by long tables in KB, for example,

      This is inconvenient.

      To make it easier to use we can embed the component version into a package version. That is, for example, Connect 1.07.0001 in MariaDB 10.4.12 could be in an RPM package MariaDB-connect-engine-10.4.12-1.07.0001-1.distro.arch.rpm, this will make it immediately clear what connect version the user is installing.

      This current task is about extending the build framework to support such combined package versions. It will not change package versions of Connect or Connector/C.

      technically this approach would make it possible to "intermediate" package versions, for example, after releasing MariaDB-connect-engine-10.4.12-1.07.0001, it would allow releasing MariaDB-connect-engine-10.4.12-1.07.0002 without re-releasing all other packages. But such an intermediate release would imply a new source rpm (or deb) package and what version will it have? It cannot be 10.4.12, that is already taken

        Attachments

          Activity

            People

            Assignee:
            serg Sergei Golubchik
            Reporter:
            serg Sergei Golubchik
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: