Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-21286

bison warnings on ubuntu 20.04 on deprecated directive in sql_yacc.yy

    XMLWordPrintable

    Details

      Description

      Generating sql_yacc.cc, sql_yacc.h
      cd /tmp/es-build/build/sql && /usr/bin/bison -y -p MYSQL --output=/tmp/es-build/build/sql/sql_yacc.cc --defines=/tmp/es-build/build/sql/sql_yacc.h /tmp/es-build/sql/sql_yacc.yy
      /tmp/es-build/sql/sql_yacc.yy:1021.1-12: warning: POSIX Yacc does not support %pure-parser [-Wyacc]
       1021 | %pure-parser                                    /* We have threads */
            | ^~~~~~~~~~~~
      /tmp/es-build/sql/sql_yacc.yy:1021.1-12: warning: deprecated directive, use '%define api.pure' [-Wdeprecated]
       1021 | %pure-parser                                    /* We have threads */
            | ^~~~~~~~~~~~
      /tmp/es-build/sql/sql_yacc.yy:1028.1-7: warning: POSIX Yacc does not support %expect [-Wyacc]
       1028 | %expect 101
            | ^~~~~~~
      /tmp/es-build/sql/sql_yacc.yy: warning: fix-its can be applied.  Rerun with option '--update'. [-Wother]
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              anel Anel Husakovic
              Reporter:
              abychko Alexey Bychko (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Git Integration