Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-19054

Unable to upgrade MySQL5.7 to MariaDB on windows

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 10.2.19
    • Fix Version/s: 10.2.24
    • Component/s: Server
    • Labels:
      None
    • Environment:
      Windows Server 2016 / Plesk onyx 17.8 / MySQL5.7

      Description

      When trying to upgrade MySQL5.7 to MariaDB10.2 it seems unable to realize that MySQL5.7 is valid, if run from cli you get.
      C:\Program Files\MariaDB 10.2\bin>mysql_upgrade_service --service=MySQL57
      Phase 1/8: Changing service configuration
      FATAL ERROR: Not a valid MySQL service

        Attachments

          Activity

            People

            • Assignee:
              wlad Vladislav Vaintroub
              Reporter:
              PureEnergy Ben Chapman
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: