Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-14600

Galera not compatible with Scons in Fedora 27

    XMLWordPrintable

    Details

      Description

      There are a couple issues I've come across when trying to build the galera-25.3.22 package on our new Fedora 27 builder.

      Here's what I do to build Galera after starting the Fedora 27 builder:

      [buildbot@fedora27-amd64 ~]$ rm -Rf buildbot && mkdir buildbot && cd buildbot
      [buildbot@fedora27-amd64 buildbot]$ mkdir rpms srpms
      [buildbot@fedora27-amd64 buildbot]$ git clone -b mariadb-3.x "https://github.com/MariaDB/galera.git" build
      Cloning into 'build'...
      remote: Counting objects: 32508, done.
      remote: Total 32508 (delta 0), reused 0 (delta 0), pack-reused 32507
      Receiving objects: 100% (32508/32508), 14.79 MiB | 4.97 MiB/s, done.
      Resolving deltas: 100% (24613/24613), done.
      [buildbot@fedora27-amd64 buildbot]$ cd build
      [buildbot@fedora27-amd64 build]$ ./scripts/build.sh -p
      ~/buildbot/build ~/buildbot/build
      ~/buildbot/build
      scons: Reading SConscript files ...
        File "/home/buildbot/buildbot/build/SConstruct", line 36
       
          print 'Host: ' + sysname + ' ' + machine + ' ' + bits
       
                       ^
       
      SyntaxError: Missing parentheses in call to 'print'. Did you mean print('Host: ' + sysname + ' ' + machine + ' ' + bits)?
      

      So the version of Scons on Fedora 27 requires print statements to have parentheses. I can work around this by adding them myself, but after doing so I then get the following error:

      [buildbot@fedora27-amd64 build]$ ./scripts/build.sh -p
      ~/buildbot/build ~/buildbot/build
      ~/buildbot/build
      scons: Reading SConscript files ...
      Host: linux x86_64 64bit
      Signature: version: 25.3.22, revision: 3764
      AttributeError: module 'string' has no attribute 'replace':
        File "/home/buildbot/buildbot/build/SConstruct", line 156:
          LIBBOOST_SYSTEM_A = string.replace(LIBBOOST_PROGRAM_OPTIONS_A, 'boost_program_options', 'boost_system')
      

      At first I was thinking that maybe both errors were due to a new version of Python on the Fedora 27 builder, it has 2.7.14, but the Fedora 26 builder has 2.7.13, so I'm guessing both issues are with Scons. The version in Fedora 27 is 3.0.0 and the version on Fedora 26 is 2.5.1. There's no older version of Scons available on Fedora 27, so the SConstruct file in our Galera repository needs to be updated to support Scons 3.0.0.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              teemu.ollakka Teemu Ollakka
              Reporter:
              dbart Daniel Bartholomew
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Git Integration

                  Error rendering 'com.xiplink.jira.git.jira_git_plugin:git-issue-webpanel'. Please contact your Jira administrators.