Uploaded image for project: 'MariaDB Server'
  1. MariaDB Server
  2. MDEV-14149

galera.MW-328A, galera.MW-328C failed with "Found wrong usage of mutex"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 10.2
    • Fix Version/s: N/A
    • Component/s: Galera, Tests
    • Labels:
      None
    • Environment:
      libgalera 25.3.14

      Description

      10.2 e99c7c8334f842a debug build

      galera.MW-328A 'innodb'                  w2 [ fail ]  Found warnings/errors in server log file!
              Test ended at 2017-10-26 03:59:38
      line
      safe_mutex: Found wrong usage of mutex 'LOCK_wsrep_thd' and 'LOCK_thd_kill'
      ^ Found warnings in /home/elenst/git/10.2/mysql-test/var/2/log/mysqld.2.err
      ok
       
       - saving '/home/elenst/git/10.2/mysql-test/var/2/log/galera.MW-328A-innodb/' to '/home/elenst/git/10.2/mysql-test/var/log/galera.MW-328A-innodb/'
      galera.MW-328C 'innodb'                  w2 [ fail ]  Found warnings/errors in server log file!
              Test ended at 2017-10-26 03:59:52
      line
      safe_mutex: Found wrong usage of mutex 'LOCK_wsrep_thd' and 'LOCK_thd_kill'
      ^ Found warnings in /home/elenst/git/10.2/mysql-test/var/2/log/mysqld.2.err
      ok
      

      Monty also reported seeing a timeout on galera.MW-328C, and there have been a couple of them in buildbot, although not recently.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jplindst Jan Lindström
              Reporter:
              elenst Elena Stepanova
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: